Jump to content
Light-O-Rama Forums
tvincek

LOR S4 not controlling.

Recommended Posts

I have S4-pro and a sandevice E6804. I have verified the E1.31 network is working with the help of Jim as Sandevices.. THANK YOU! Jim!!

so we used Sacnview to determine LORS4 is not sending/communicating out.. which I can see the network lights flashing on the controller, not nothing happens.

Network configured/multicast/ RGB channels in/"control lights checked"

suggestions please

IMG_1404.JPG

IMG_1405.JPG

IMG_1406.JPG

Share this post


Link to post
Share on other sites

First things first, on the top menu click "PLAY" and make sure "Control Lights" is checked.

Share this post


Link to post
Share on other sites

I can't see the pics very well nor do I know the Sandevices very well but I do notice in your network config pic that each universe has its own ip address. Doesn't the Sandevice get one ip address?

The universes should have the ip address of the Sandevice. Am I wrong about the Sandevice?

Example: I have an Alphapix16 with one universe assigned to each output (16). Each - output is assigned the ip address of the card.

Edited by Mr. P

Share this post


Link to post
Share on other sites

I am in multicast...not sure what it should be...  LOR ticket guys says 239.255 are invalid IP's but they are the default when using mulitcast.. I can change if I go to unicast

 

Share this post


Link to post
Share on other sites
29 minutes ago, tvincek said:

I am in multicast...not sure what it should be...  LOR ticket guys says 239.255 are invalid IP's but they are the default when using mulitcast.. I can change if I go to unicast

 

Your IP address on the Sandevice should be in the same octet as your computer. If your computer is 192.168.1.1 then you device should be say 192.168.1.10

All universes on that device should be 192.168.1.10

Multicast is mainly if you have several devices with several ip addresses.

Edited by Mr. P

Share this post


Link to post
Share on other sites

First off make your life easier and go over to unicast, and set the IP addresses. What is the IP address of your computer? For example the boards come from Jim pre set to up to an IP address. But my computers ip is is in the IP addresses of 169.254.74.##. Take 10 minutes and change over to unicast and go from there. Also remember that you need to have your LOR dongle plugged in if you have a LOR network or the lights won't work, and you need to make sure you have the comm lister opened or the E1.31 lights won't work

Sent from my iPhone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys! Will try several of these and report back tomorrow

Share this post


Link to post
Share on other sites

In your screen captures, you are in multi-cast on both the LOR end and the E6804 end (and yes, I know E6804s really well).  It should work OK from a networking standpoint.  I agree with 1983ss454 that going unicast is better, but for the moment that can be ignored.  As a networking guy, I hate multi-cast except where it is absolutely needed (and it's not here).

I don't see the LOR light bulb in your system tray (but the photo is really dark so I may have missed it), so I'm wondering if you started the LOR Control Panel (which will start the Comm Listener).  Without that, it absolutely will not work.

Also, since it looks like you are using a Windows version newer than Windows ME (barf!), I would suggest finding the Snipping Tool.  That was introduced in Windows 7 and does a FAR better job of a screen capture than taking a photo of your screen with a camera (which is what it looks like you did).  Here is a little demonstration of the difference.  This first is a photo of the screen:

Photo.jpg

And the next one is a screen capture:

Capture.jpg

Yes, it was a slightly different capture...

 

 

  • Like 1

Share this post


Link to post
Share on other sites

From what I can see (I think)

Sandevice - 169.254.124.145  (may be the computer)

universe 1 - 239.255.0.1

universe 2 - 239.255.0.2

universe 3 - 239.255.0.3

universe 4 - 239.255.0.4

Edited by Mr. P

Share this post


Link to post
Share on other sites

The universes are normal for multi-cast.  I just brought up Network Configuration on this computer and selected universe 5 and told it to be multicast.  I then selected the box at the bottom to create 6 with that configuration.  they came as 239.255.0.5 - 239.255.0.10.  With LOR sending multicast, it does not matter at all what the IP is for the SanDevices card.

 

Share this post


Link to post
Share on other sites
2 minutes ago, k6ccc said:

The universes are normal for multi-cast.  I just brought up Network Configuration on this computer and selected universe 5 and told it to be multicast.  I then selected the box at the bottom to create 6 with that configuration.  they came as 239.255.0.5 - 239.255.0.10.  With LOR sending multicast, it does not matter at all what the IP is for the SanDevices card.

 

So on a Sandevice each universe gets an ip and not the device itself? 

Share this post


Link to post
Share on other sites

No.  The SanDevices always has one IP address for the board.  It is the LOR Network Preferences that assigns a psudo-IP address for each universe ONLY WHEN operating in multi-cast.  When setting each universe for uni-cast, you would specify the single IP address for the SanDevices card that is supposed to respond to that universe.  Since the original poster is using multi-cast, LOR assigns the dummy address in the 239.255.x.y range (where for universes below 256, x = 0 and y = the universe number - universe 256 starts the 239.255.1.y range).

So, for Multi-cast ONLY, the IP addresses shown in the Network Configuration are correct, and the address of the SanDevices card is absolutely irrelevant.

 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, k6ccc said:

No.  The SanDevices always has one IP address for the board.  It is the LOR Network Preferences that assigns a psudo-IP address for each universe ONLY WHEN operating in multi-cast.  When setting each universe for uni-cast, you would specify the single IP address for the SanDevices card that is supposed to respond to that universe.  Since the original poster is using multi-cast, LOR assigns the dummy address in the 239.255.x.y range (where for universes below 256, x = 0 and y = the universe number - universe 256 starts the 239.255.1.y range).

So, for Multi-cast ONLY, the IP addresses shown in the Network Configuration are correct, and the address of the SanDevices card is absolutely irrelevant.

 

Thanks, good to know. I only use uni-cast so I didn't know multicast did that.

Share this post


Link to post
Share on other sites
1 minute ago, Mr. P said:

Thanks, good to know. I only use uni-cast so I didn't know multicast did that.

Same here.  I normally only use Uni-cast.  Although I don't control lights or sequence here, I have a full installation of S4 on this XP computer.  I think I have brought up Network Configuration three or four times today because of this thread because I needed to make sure I knew how Multi-cast behaved at the LOR end.

 

Share this post


Link to post
Share on other sites

Here is where I am at this morning:  ran Ipconfig all: my PC is 169.254.124.xxx (see screen capture)

I set the controller to 169.254.124.10/multicast (tests just fine from web page interface universe 1- 20 pixels)

LOR dongle connected

removed all previous network configurations in LOR - shut down and restarted LOR

made 1 new universe in the network configuration - from the control pannel 

 shut down and restarted LOR

opened the control panel and verified the listener was running

opened the sequence editor

inserted below a new device with 1 universe 20 pixels (to agree with my E6804  settings)

told all 20 pixels to turn white - 20 seconds

saved the test sequence

made sure CONTROL LIGHTS IS ON

made sure allow DMX editing is checked

still nothing - I can see the network lights flashing on the controller, but no pixels come on

I can see the network lights flashing on the controller, but I get no lights.

still stuck

 

Capture3.PNG

Capture2.PNG

Capture1.PNG

Share this post


Link to post
Share on other sites

Yes- test fine from the web interface... I also loaded up Xlights and ran a test in Xlights and they work fine from Xlights.

   I want to use S4 though...

Share this post


Link to post
Share on other sites

One thing I have noticed and maybe someone can clarify. In the second pic the comm listener port is 8837 and the DMX Universe port is the same 8837, mine are different at 8837 and 5568 and work perfectly fine. Could it be that they are trying to use the same port?

  • Like 1

Share this post


Link to post
Share on other sites

Is your computer set up for DHCP? 

I ask because you have selected what is called an APIPA address. This is an alternate address set (class B ) that is used when a DHCP request fails. 

APIPA addresses are very limited in what they can do. Yes. they can communicate among themselves but ...

Also note.... in your IPCONFIG image. It is running autoconfig. note that you will get a different address to the PC everytime you boot. 

 

If this is a dedicated NIC card. Set the IP static ... 

10.10.10.254 255.255.255.0

Start you devices at the bottom ... 10.10.10.1  255.255.255.

Fix your network config in LOR and you should be up and running.. 

This is the exact setup I use.. I have LOR, Sandevices and J1Sys.. all running happy and fast.. 

 

Bob 

 

Share this post


Link to post
Share on other sites

I set the NIC to 10.10.10.254 the subnet mask defaulted to 255.0.0.0

I updated the controller to 10.10.10.1 subnet default of 255.0.0.0

tests fine from web interface and Xlights - still nothing in LOR

I am working with Scooter Paschall, he remoted in - he is stumped too.

 

Share this post


Link to post
Share on other sites

Is the LOR Control Panel running?  Without that, you will not be able to control your lights.

When it's running, you should see connection messages for all of your network devices.

Walt

Edited by wbaker4

Share this post


Link to post
Share on other sites

Also since you loaded Xlights, make sure it is NOT loaded or running when working with LOR ... 

I have had weird results when both are present. 

As Walt mentioned, make sure the LOR control panel is running. 

Also make sure you can ping the SanDevice ... from a command line issue ping 10.10.10.1 and make sure you are getting a reply 

 

Bob 

 

  • Like 1

Share this post


Link to post
Share on other sites

Let me throw one more shotgun load in the chamber. 

Turn off your Windows Firewall (all of it .. PUBLIC and HOME) ... 

I always see my LOR connections on the PUBLIC side .. but to make testing easy .. shut down all of it .. 

Also if you don't use Windows firewall, shut down any 3rd party firewall you may have running. 

I just tested this on my machine ... Firewall --- no LOR... Firewall OFF.. LOR good .. 

If that resolves the issue, you can turn the firewall back on and then set the Pubic side to block inbound and ALLOW outbound traffic. 

 

Bob 

 

 

Edited by bob_moody

Share this post


Link to post
Share on other sites

thanks guys. Turned off fire wall. Still no go.... I wonder if I should I un-install LOR and reinstall.... I can see the network lights flashing on the controller... comm control panels says connected...but no pixels come on.... it's just odd. Web interface- works... xlights - works....Sacnview-works...pings fine.... LOR no go... However it does work with my ctb16pc on the LOR dongle..

Edited by tvincek

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...