Jump to content
Light-O-Rama Forums
asl9622

Setting ID's for Pixcon 16

Recommended Posts

Hey ladies and gentlemen,

I need your help on this one. I have successfully installed my power supplies to my Pixcon controller. I was able to configure the controller for 2811 lights and to use the LOR network. I have the pro license to save intensity data files etc. I have programmed a song in pixel editor and sequence editor and saved the intensity file. I see on the top of sequence editor the intensity file. However when I play the show with Control lights on, the lights do not turn on that are connected to Pixcon.  On the controller the light is steady indicating a data connection. I have high speed network enabled. I also ran the pixcon self test and it does controller the lights RGB and white. My thinking is that I do not have the correct node, id fun stuff set up in the preview in pixel editor to match the configuration. I started with unit ID 6. To be honest with you I am not sure what the nodes portion is. If anyone can help me in explaining how to set the ID in configuration to match the preview in Pixel editor, then that would be greatly appreciated. I know I am so close to having this work. Thanks!

 

I am running sequence editor 4

Share this post


Link to post
Share on other sites

Did you start the LOR control panel?

 

Share this post


Link to post
Share on other sites

No I did not. The only time I have ever really used the control panel is when I have a show created. I apologize as I realize I did mention show in my original post. I created a sequence and am trying to use sequence editor "control lights" option enabled just to run a quick test. I am pretty sure the problem lies in the Unit ID assignment and it not correct in pixel editor to what I checked for configuration. 

Share this post


Link to post
Share on other sites

With S4, you do need the control panel running in order for much of anything to control lights (except the HU).

 

Share this post


Link to post
Share on other sites

Control Panel is running and says it is connected to Com Listener. I checked config for the Pixcon and i have the ID going 6 7 8 9 0A.....15. I have to match those to each strand in the pixel editor preview correct?

Share this post


Link to post
Share on other sites

Not having the control panel running is a very common error with S4 users.  It is a new requirement.

Can't help you with PE as only played with it a little during the beat almost a year and a half ago (and never could do anything useful with it).

 

Share this post


Link to post
Share on other sites
Just now, k6ccc said:

Not having the control panel running is a very common error with S4 users.  It is a new requirement.

Sure gets me to thinking how easy V1 was back in the day. LOL :)

As a matter of fact, I have an old computer that still has V1 from 2005. B)

Share this post


Link to post
Share on other sites

Well I reset my computer thinking, " Hey can't hurt" and now the data connection light is blinking. Dinner break and then trouble shoot time. 

Share this post


Link to post
Share on other sites

Thanks to the light o rama support team we were able to get the lights playing and all the ids correct. However I noticed that all though everything is working the lights displaying on the strip are not the same on the computer. For instance blue will be green red will be blue etc. Any idea what is going on. I am confident i have the controller configured to be RGB and lights in pixel editor set the same way. Any help would be appreciated.

Share this post


Link to post
Share on other sites

The strips you are using are they "CCR's" or smart strips? If you don't have LOR's CCR then the strips you have are probably set to a different output order instead of RGB it could be.....BRG, GRB, GBR...etc. set the controller accordingly to the correct color output. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks bill. The lights are from holiday coro and the packaging says BRG. I have adjusted the preview in pixel editor to reflect this as well as in the network configuration for the board. However the lights are still not correct. Did I miss something?

Share this post


Link to post
Share on other sites

You should only adjust the color order on the Pixcon.  Your sequencing should reflect the "normal" RGB order.  The Pixcon will adjust the color order to the actual order needed by those pixels.

 

  • Like 1

Share this post


Link to post
Share on other sites

What K6ccc stated. Once you set the Pixcon color output it will do the rest. You shouldn't have had to do anything in the PE.  You should undo what you did in PE and see if that helps. 

Share this post


Link to post
Share on other sites

Thanks for the responses. Switched it back in PE but still have the same problem.

Share this post


Link to post
Share on other sites

Did you change the rgb color output on the right port for your lights.

Share this post


Link to post
Share on other sites
1 minute ago, Dennis Laff said:

Did you change the rgb color output on the right port for your lights.

I believe so. I have a screen shot but the file is too big. I changed every unit Id to the correct setting.

Share this post


Link to post
Share on other sites

I've never used a Pixcon, but most of the pixel controllers have test modes that will changed all the pixels to a particular color.  If the Pixcon has that ability, you can verify that the color order settings are right.  First step of the test is to set the color order in the Pixcon to RGB.  Then set everything to Red.  If the lights are not Red, note what color they are.  Same thing for Green and Blue.  From those tests, you should be able to determine the actual color order.  then set the color order in the Pixcon to what you THINK you determined, and repeat the test to confirm that you got it right.  There is no point in proceeding with sending sequences until this part is right.

 

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, k6ccc said:

I've never used a Pixcon, but most of the pixel controllers have test modes that will changed all the pixels to a particular color.  If the Pixcon has that ability, you can verify that the color order settings are right.  First step of the test is to set the color order in the Pixcon to RGB.  Then set everything to Red.  If the lights are not Red, note what color they are.  Same thing for Green and Blue.  From those tests, you should be able to determine the actual color order.  then set the color order in the Pixcon to what you THINK you determined, and repeat the test to confirm that you got it right.  There is no point in proceeding with sending sequences until this part is right.

 

Thanks for the reply. There is a test mode that you hold down a button and it will cycle between R,G, B, White. I just do not remember the order. I will take your advice and write down the colors that display in the test sequence after changing the Pixcon back to RGB.

Share this post


Link to post
Share on other sites

Besides pressing the "Factory IP " button on the Pixcon16, the newest LOR Hardware Utility can also be used.

 

Share this post


Link to post
Share on other sites
19 minutes ago, Vince4xmas said:

Besides pressing the "Factory IP " button on the Pixcon16, the newest LOR Hardware Utility can also be used.

 

I appreciate the heads up. I did notice that on the hardware tool but for whatever reason I cannot get it to work or sync. The controller works perfect with sequence editor and pe but when I open hardware utility it has to close those to function. At that point the data led on the board is blinking saying it is not receiving. I still try to send the light commands but nothing turns on.

Share this post


Link to post
Share on other sites

Have you upgraded the Pixcon16 with the newest firmware?

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...