Jump to content
Light-O-Rama Forums
Ed K

Select the Location in SuperStar’s Grid to Place a Text Effect

Recommended Posts

At the bottom of SuperStar’s Smooth Effects mode window is an option to manually clip the sequencing grid rectangle where the smooth effect appears.  The same manual clip option also is provided at the bottom of the Text mode window.  

However, after clicking on the Manual Clip radio button in the Text mode window, and holding down the SHIFT key wile selecting the rectangle on the SuperStar sequencing grid where I want the text effect to be, SS does not move the text effect to that area I just manually clipped.  

Any suggestions?  Do I need to make some change to my Visualizer file (e.g., add a text string to the prop on which I want to place the text)?  
 

Share this post


Link to post
Share on other sites

Changing the location of the clip rectangle changes the region which will display what the effect does, it does not change the location of the effect. You can put the effect where ever you want.

Let me know if I am misunderstanding your question.

Share this post


Link to post
Share on other sites

Now that I have re-read your question, I think what you are wanting the clip rectangle to allow you to specify what you want the text and then you want superstar to squish or stretch the text to fit the rectangle. This would be a cool feature, but that is not what the clip rectangle does. Think of the clip rectangle as defining a viewing screen. If you do a text action on your lights, the text action might start outside of the left side of the clip rectangle and could end up outside of the right edge of the clip rectangle. But you only want to see the text when it is in the clip rectangle. This is particularly useful if you have two matrixes in your display. In that case you might want some text to scroll across one matrix, but you don't want it to "bleed" over to the other matrix.

Or if you have just one matrix and you have some other lights in your visualization, you want the text to only be seen within the matrix, the clip rectangle prevents the text from "bleeding" onto your other lights. 

Share this post


Link to post
Share on other sites

Exactly how you just describe it:  I just want the text to appear in one of my two mini matrices.   I want my viewing area to be the clip rectangle 

In my example, I want text to start outside the right side of the clip, move leftward across my clip rectangle, and end up outside the left side of my clip rectangle.    This is exactly how you  show it in your basic text video (though your text moves vertically, and you have just one prop in the video).  

 The manual clipping tells SS where reveal the text as it moves from outside, then inside the clip rectangle, than back outside the rectangular "viewing area".  

I get this to work in a small, test SS file, which has just two mini matrices.  I clip a rectangle around the sequencing boxes for one of the two matrices.  The text begins outside, goes across just the one matrix, and ends up outside the other side of the clip rectangle.  In my SS file with multiple props, with the same two mini matrices, it's not working.  Just a few pixels turn on, and they're on other props.  

In Visualizer, I let SS decide if these are matrices, and I don't have any text strings in the comment field of either mini matrix.

I hope this isn't too confusing. 

 

 

Share this post


Link to post
Share on other sites

Please email your visualization file and sequence file to brian@superstarlights.com and I will take a look at it

The visualization file will end with .lee and should be at:

c:/ (your lightorama folder) / Visualizations / Edtior

 

The sequence file will end with .sup and should be at:

c:/ (your lightorama folder) / Superstar / Sequences

Share this post


Link to post
Share on other sites

Sent

Share this post


Link to post
Share on other sites

I looked at the files. For the text, the start x,y is 43, 59 and the end x,y is -35, 59. Change the y coordinate in the start and end to be something like 44 instead of 59 and then it will be visible in the clipping rectangle that you have.

I think I now understand your initial posting. I expect you used the "Left" button in the group that is labeled "Direction of Motion" and that is what gave you the start and end coordinates of 43,59 and -35,59. The problem is that currently the code centers the text within the entire sequencing grid when you use the buttons under "Direction of Motion." What would be better is for the code to center the text within the current clipping rectangle when you are using the buttons under "Direction of Motion".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...