Jump to content
Light-O-Rama Forums
beckntrav

E1.31 / DMX Universe not talking to PixCon16

Recommended Posts

First attempt at E1.31 & DMX to incorporate, so it could be a simple mistake.

 

I was able to set the PixCon16 board to IP 192.168.1.202.  My computer is off network and set to 192.168.1.3. When I hook the ethernet cord from the PC network card to the PixCon16 Ethernet connector, I can successfully update the card settings.  I've also set the network preferences for universe 1 to match the cards IP.  I then hook the card up to my USB485 adapter and have tried to connect to both the ethernet connector and the DMX port.   Pixcon16 status and power lights blink together no matter what I try.

 

Am I supposed to use the USB485 adapter to connected the PixCon16 to my PC? Which PixCon16 socket should I be using?

 

Here's my adapter.:

http://store.lightorama.com/uscoad.html

Edited by beckntrav

Share this post


Link to post
Share on other sites

Don't use the adapter, connect Pixcon 16 to Ethernet port and that's it, connect to a network switch if your going to use more than one E1-31 controller

Share this post


Link to post
Share on other sites

NO

You may have broken something. RS485 and Ethernet are different. They just both use the same connector. 

 

I knew the Pixcon 16 would cause more people to plug stuff into the wrong hole.

Share this post


Link to post
Share on other sites

I also just received 4 Pixcons and am tryin to test various functions today.  If anyone has succesfully connected a Pixcon bridged DMX output to a CMB24, please let me know what you did to achieve it.  This is what I have done so far.

 

These are the steps I have taken:

1) Updated Pixcon firmware from 1.4.6 to 1.48
2)Connected a single Pixcon to the computer directly-no switch, no router, no hub
3) Used LORPixCon Utility and searched for units, found the one I had previously set up and identified as Static, Pixcon 51 (showing firmware to be V1.4.8)
4)Clicked on the Control Tab and selected Ethernet Protocol and set sACN to DMX512 Output #1 to Universe 1 and turned it on
 ( BTW, sACN t DMX512 Outputs 2,3 and 4 started at 0, I changed them to 1, then back to 0 but they will not stay at 0; they go back to 1 whether they are turned on or off--SO they are all 4 on 1, but only output 1 is turned on)
5) Clicked Advance tab and selected Output 1 to start at Universe 3, Start Channel 1, Output 2 to Universe 4, Start Channel 1 and so on... (so there would be no conflict with #4 above)
6)Clicked OK all the way out
7)Then connected the ethernet port on my computer to the ethernet port on Pixcon 51 (after moving the jumper pin from ESTA to LOR)
8)Then connected the bridged DMX output 1 on the Pixcon to the RJ45 on a CMB24
9) Connected a dumb pixel strip to channel 1 of the CMB24
10)At this point the green light on the Pixcon is solid, the red is flash blinking.  The red light on the CMB24 is solid red
11)Closed the Pixcon utililty
12)Opened the Comm Listener
13)No usb adapter are installed ever throughout this test
14)Opened the Hardware Utility and selected Pixel console
15)Checked DMX Pixel (E1.31) and got the pop up dialog box telling me to Ensure Listener is Running-which it is so i check OK
16)Set the universe to 1 and click on Controller White On button at the bottom
17)Nothing happens and the red light on the Pixcon is still fast blinking red and the red light on the CMB24 is still solid red

Shouldn't the dumb pixel strip in channel 1 of the CMB24 be on now and shouldn't I have connectivity?

PS.  I did the same test with a 1602 AC controller with the same results (status lights on 1602 solid, but no lights)

Edited by Charles Belcher

Share this post


Link to post
Share on other sites

Check the manual it test mode it runs a test on the 16 ports on the board not the DMX to E1-31 you might need to run a sequence that has your cmb-24 in it to test those ports

Share this post


Link to post
Share on other sites

Check the manual it test mode it runs a test on the 16 ports on the board not the DMX to E1-31 you might need to run a sequence that has your cmb-24 in it to test those ports

Dennis,

 

I ran both a sequence and went to the Pixel console in the hardware utility also.  (Pixel console is what DevMike suggested before I did all that(

Share this post


Link to post
Share on other sites

What universe is the cmb- 24 set to and is it in the Dmx mode

coming out of the DMX Out #1 of the Pixcon with the jumper block in the LOR position (in ESTA position the red light on the CMB24 blinks) to the RJ45 input on the CMB24--should be just that easy-right?

Share this post


Link to post
Share on other sites

You will only get output signal to DMX with advanced lic or pro lic do you have either one?

Share this post


Link to post
Share on other sites

You will only get output signal to DMX with advanced lic or pro lic do you have either one?

Yes, my avatar doesn't show it correctly.  I have the latest and greatest pro version of S4.  I have done more testing.  The CMB24 works correctly directly with a usb485 adapter and works correctly with a usb485 adapter/IDMX1000/special cable

Really at a loss here and have turned in a "ticket".

Share this post


Link to post
Share on other sites

Do you have the jumpers on the CMB24D board set to DMX

 

Don't do that.  They should be left in LOR mode since the PixCon16 has already been changed from ESTA to LOR pinouts.  Setting it to DMX will just re-set the pinouts to an incorrect state.

 

:LOR on one side, LOR on the other ;)

Share this post


Link to post
Share on other sites

Even if he has the pixcon on E1-31?

Yes.

Share this post


Link to post
Share on other sites

Are you sure I'm reading the manual and its lor in lor out but not with E1-31 in Ethernet connection

Share this post


Link to post
Share on other sites

Are you sure I'm reading the manual and its lor in lor out but not with E1-31 in Ethernet connection

Yes, Dennis.  Dev Mike knows.  He wrote the manual for the pixcon.  I have verified via status lights by moving the pins back and forth.  

Share this post


Link to post
Share on other sites

Yes.

Mike,

 

If you are not the one answering my help desk messages today, let me fill you in on the latest.  I can tell you that I started all over from the beginning.  I did a factory reset with both buttons on the pixcon and got back to the default ip address of 192.168.0.50.  It is showing firmware 1.4.8 (even though it I did a reset and it was delivered with 1.4.6 firmware)

 

 

I am connected from a stand-a-lone laptop with no wireless connected direct to the one and only pixcon.  I then opened the comm port listener, then opened Network Config program, listed as v4.1.2Pro.

I clicked Help Find Pixcon button and it found it, highlighted in RED, and shows 192.168.0.50, LOR PixCon16, Default Nickname -V1.4.8 and the MAC address.  But when I click on it, I get an error message which says:

"You can not configure this board because the program does not know how to deal with that version of firmware.  You may need a software upgrade."

 

Where do I go from here?

 

Charles

Edited by Charles Belcher

Share this post


Link to post
Share on other sites

Everything is all good now.  Bridges are built and there is traffic across them.

 

Found ALL the jumpers, huh?  ;):P

Share this post


Link to post
Share on other sites

Found ALL the jumpers, huh?   ;):P

DevMike,

 

I would say something clever here, but...I can't seem to talk with all the egg on my face.  (☞ ͡° ͜ʖ ͡°)☞

Share this post


Link to post
Share on other sites

DevMike,

 

I would say something clever here, but...I can't seem to talk with all the egg on my face.  (☞ ͡° ͜ʖ ͡°)☞

 

Don't feel bad.  I went back through the PixCon16 documentation and can see where it would be confusing (since I only circled the one set of jumpers in the picture).  I went ahead and updated it so people know that each one has a set.  

 

In other words, the egg actually tasted pretty good! :D  No harm no foul.

 

(edit:  Chicken puns?  COME ON!)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...