Jump to content
Light-O-Rama Forums
k6ccc

JRW07 - Show player status window not updated unless window is open

Recommended Posts

Summary:  Show player status window does is not updated unless the status window is open.  In 3.12.2 (and as far as I know - all previous versions), if part way through the show the status window was opened, it would display all the events since the show player was started.

Module:  Show player status window

Version:  4.0.32

OS:  Windows XP

Description:  In prior versions of LOR software, the information in the show player status screen would be updated even if the show player status display window was not active.  Therefore, if for example several hours into the show, the status display screen were to be activated (by left clicking the LOR lightbulb in the system tray), it would show all activity since startup (or bootup in my case).  I moved my show computer from 3.12.2 to 4.0.32 a few days ago and first noticed this problem now.  Below is a copy of the status window for this evening.  Below it I will annotate it a bit:
 

15:50:43: Comm Listener error 3: Comm Winsock Error / 10061: Connection is forcefully rejected
21:59:39: Trigger detected: Regular, Unit 05, Input 1
21:59:39: Starting Interactive: L:\Sequences\Steps up from door 2012-11-18.las
21:59:50: Trigger detected: Regular, Unit 04, Input 3
22:00:00: Clearing triggers
22:00:00: Current show is entering shutdown mode
22:00:15: Ending Musical: L:\Sequences\Landscaping evening with colors 2015-05-11.lms
22:00:15: Stopping Interactive: L:\Sequences\Steps up from door 2012-11-18.las
22:00:15: Stopping Interactive: L:\Sequences\Steps up from door 2012-11-18.las
22:00:15: Ending Interactive: L:\Sequences\Steps up from door 2012-11-18.las
22:00:15: Finished show: L:\Sequences\Year-round_Evening.lss
22:00:15: Starting show: L:\Sequences\Year-round_Overnight.lss
22:00:15: Loading sequence: L:\Sequences\Landscaping transition 2014-08-03.las
22:00:16: Loading sequence: L:\Sequences\Landscaping overnight 2014-08-03.las
22:00:16: Loading sequence: L:\Sequences\Steps up from door 2012-11-18.las
22:00:17: Loading sequence: L:\Sequences\Steps up from walkway 2012-11-18.las
22:00:17: Loading sequence: L:\Sequences\Steps up from driveway 2015-04-06.las
22:00:17: Loading sequence: L:\Sequences\Walkway up from porch 2014-04-21.las
22:00:17: Loading sequence: L:\Sequences\Landscaping shutdown 2014-08-03.las
22:00:18: Starting Startup: L:\Sequences\Landscaping transition 2014-08-03.las
22:00:28: Ending Startup: L:\Sequences\Landscaping transition 2014-08-03.las
22:00:28: Registering interactive triggers
22:00:28: Starting Animation: L:\Sequences\Landscaping overnight 2014-08-03.las
22:01:30: Trigger detected: Regular, Unit 04, Input 2
22:01:30: Starting Interactive: L:\Sequences\Steps up from walkway 2012-11-18.las
22:01:31: Starting Interactive: L:\Sequences\Walkway up from porch 2014-04-21.las
22:01:36: Trigger detected: Regular, Unit 05, Input 1
22:02:16: Ending Interactive: L:\Sequences\Steps up from walkway 2012-11-18.las
22:02:31: Ending Interactive: L:\Sequences\Walkway up from porch 2014-04-21.las
22:04:28: Ending Animation: L:\Sequences\Landscaping overnight 2014-08-03.las
22:04:28: Starting Animation: L:\Sequences\Landscaping overnight 2014-08-03.las
22:16:28: Ending Animation: L:\Sequences\Landscaping overnight 2014-08-03.las
22:16:28: Starting Animation: L:\Sequences\Landscaping overnight 2014-08-03.las
 

 

Now for some comments.  The show PC gets rebooted at 15:50, so the first log entry shows a non-graceful startup.  That part is not an issue.  What did not show however is that at 16:00:00, the evening show was started (although waiting for a startup trigger).  The trigger happened just after 20:00.  From then on, there should have been sequences starting and ending every four minutes.  Additionally some interactive sequences also ran, but were not show at all.  Because I wanted to watch the transition from the evening show to the overnight show, I opened the show player status window, and then walked outside.  Opening the front door triggered unit 05 input 1 which correctly started interactive sequence Steps up from door.  A few seconds later I walked through a different trigger as seen at 21:59:50, however that correctly did not do anything because of the type of interactive group.  At 22:00:00 the evening show entered shutdown and as soon as it ended the overnight show started.  There is only one animation that is exactly four minutes long in the overnight show (plus a collection of interactives plus a startup and shutdown sequence).  You can see the overnight sequence start at 22:00:28 and again four minutes later at 22:04:28.  Shortly thereafter I closed the window and then opened it again about 10 minutes later.  You can see what should have logged at 22:08:28 and 22:12:28 did not log, however after re-opening the status window, the overnight animation started again at 22:16:28

 

BTW, I just tried minimizing the status display window and walked outside to trigger an interactive sequence group.  After coming back inside, I restored the status display window and the interactive was shown.

 

 

Share this post


Link to post
Share on other sites

I have noticed this behavior in 4.0.32 too.

 

W7 64 Pro

 

On a related note, is the font in the lower status window a bit small now?

Edited by PhilMassey

Share this post


Link to post
Share on other sites

Thanks for the report. I can reproduce this, and we'll try to get it straightened out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...