Jump to content
Light-O-Rama Forums
Sign in to follow this  
PhilMassey

Lines effect in PE question

Recommended Posts

Having trouble getting the lines effect to work in PE. Before the addition of the different line types, all was well but now I can't get the effect to work on actual lights.

 

Setup is this. Two strings of 2811 square nodes 108 pixels each, Universes 1 and 2, doing roof-line duty.

Sandevices 6804 unicast.

 

Using lines unconnected, and entering 2 segments and 216 total nodes, the max channel numbers show 648 for both Uni''s. This is clearly wrong and won't accept when you push OK ( rightly so.)

Tried using 108 total nodes and the max channels show the correct 324 values, but only one universe lights on the actual lights. It seems to be OK on the PE preview. Works fine from the SE or show player.

 

Not sure if it's me or a potential bug.

 

Update:

Tried entering the 2 segments as two separate props, Eaves 1 and Eaves 2 and it seems to be working now.

Edited by PhilMassey

Share this post


Link to post
Share on other sites

As you discovered, the new Lines props must be all in one universe (DMX) or one unit id (LOR).

Share this post


Link to post
Share on other sites

Doesn't that mean I can't run an effect from one end of the house to the other through both props in sequence, since the are now in effect, in paralelle. Too many pixels to fit in one universe. Worked OK  with the simple line prop. ( I think) Again, this is with actual light strings, not preview.

Share this post


Link to post
Share on other sites

Doesn't that mean I can't run an effect from one end of the house to the other through both props in sequence, since the are now in effect, in paralelle. Too many pixels to fit in one universe. Worked OK  with the simple line prop. ( I think) Again, this is with actual light strings, not preview.

 

You should create a prop group containing however many segments are on your house. In the prop group editor, arrange the props from left to right and then select "horizontal stack". Now apply effects to the group.

 

As an example, my roofline looks like this:   _/\__ 

I have this modelled as 4 segments: left gutter, left eave, right eave, and right gutter.

I have all 4 in a horizontal stack so I can apply effects to the entire roofline.

I also have just the 2 eaves in a horizontal stack so I can apply effects just to them.

They are also part of my whole house prop - so I can apply an effect to the entire display.

 

Matt

Share this post


Link to post
Share on other sites

Ah, so the step I was missing was groups. I'll give that a try. Thanks, Matt

Share this post


Link to post
Share on other sites

 

 

Not sure if it's me or a potential bug.

 

Actually there is a bug in 4.0.14 regarding lines. It calculates the wrong number of channels if the number of segments is not 1. I think this is what you were describing in your original post. This will be fixed in 4.0.16.

Share this post


Link to post
Share on other sites

I'll check it out after the next update.

Thanks Matt.

Share this post


Link to post
Share on other sites

MB02 - Problem with lines in PE

Share this post


Link to post
Share on other sites

It seems to be doing better with 4.0,16.

 

One comment though. Is the number of pixels supposed to be for ALL the strings combined or is it "per string". 

The total channels at left is wrong if you put in the TOTAL number of nodes as is suggested by the wording.

 

For my two strings of 108 pix, if I put in 216, which IS the total number of pixels, it gives 648 ch for each.

If I put in 108 which is not what the wording suggests, I get the proper 324 ch in each.

This is in lines unconnected.

 

Thanks again for all your hard work, Matt and Mike.

Share this post


Link to post
Share on other sites

Unfortunately the fix did not get included in today's release (my fault). You will need to wait for the next release.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...