Jump to content
Light-O-Rama Forums
Sign in to follow this  
dgrant

DG01 - Duplicate DMX Pixel Fixture Channels do not render

Recommended Posts

Not sure if related or not...I added my pixel tree, which rendered normally without issue, while playing. However, when I added a second pixel tree, both trees only partially play. Some of the strips/strings don't work. I even connected both to the same set of channels in the hardware and still again, both only partially respond. I deleted the second tree and the first one was back to normal playing all strings/strips/nodes.

Share this post


Link to post
Share on other sites

Not sure if related or not...I added my pixel tree, which rendered normally without issue, while playing. However, when I added a second pixel tree, both trees only partially play. Some of the strips/strings don't work. I even connected both to the same set of channels in the hardware and still again, both only partially respond. I deleted the second tree and the first one was back to normal playing all strings/strips/nodes.

This is a different issue.  Please send me both visualizer files as well as the LMS.  mike @ lightorama.  Thanks!

Share this post


Link to post
Share on other sites

This is a different issue.  Please send me both visualizer files as well as the LMS.  mike @ lightorama.  Thanks!

Sent

Edited by dgrant

Share this post


Link to post
Share on other sites

Please re-test with 4.12.  Duplicate DMX pixel fixtures should not be allowed and should be flagged with a compile error.

Share this post


Link to post
Share on other sites

I removed the second tree in hopes of creating the proper one with the proper channels. Problem is, your sample tree (16x50-packed dmx) is perfect however, I need it as a prop so I can import it into my lee file. I tried exporting it one string at a time but I couldn't line it up as nice as what you all did. Looked like a mess. I agree the channels shouldn't be duplicated.

Share this post


Link to post
Share on other sites

Sorry, I was not clear.  Can you open that file in the newest version of the beta, and when you put it into simulation mode, do you get the message box saying you can't go into simulation because of dupes?

Share this post


Link to post
Share on other sites

Sorry, I was not clear.  Can you open that file in the newest version of the beta, and when you put it into simulation mode, do you get the message box saying you can't go into simulation because of dupes?

 

I tried that just now in 4.0.12. The duplicate tree with identical channels went in and was accepted. No error message or warning was given in the Visualizer

 

Share this post


Link to post
Share on other sites

Crow.  That should not be happening.  I thought I caught all the issues in the compile routines.  Guess I didn't....

Share this post


Link to post
Share on other sites

I only did a simple copy and paste of the entire tree prop. Ran it, it ran. Saved it, it saved. Tree is DMX based channel assignments

Share this post


Link to post
Share on other sites

Double Crow.  Now I know why I thought I fixed this and didn't.  I confused your test files with files from someone else.  I found your eMail, but it looks like you have deleted the files from your drop box.  Can you put them up again for me and eMail me the location?

 

Sorry about that, completely MY fault.

Share this post


Link to post
Share on other sites

Just got home and saw this, sent you just the LEE file this time directly. Confirmed again that in 4.0.12, it will allow duplicate channels which causes problems for them displaying properly. Understood that its not suppose to allow them

Share this post


Link to post
Share on other sites

Thanks again.  This time I found it and fixed it.  You should get the error from now on once we update the beta again.  

 

Sorry for loosing your files the first time.

 

Rev 14443

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...