Jump to content
Light-O-Rama Forums
plasmadrive

Lost my first triac (the story)

Recommended Posts

Yesterday and last night we had a storm with very high winds and a good deal of rain.   My show rain last night without issue.  I got us this morning and there was darkness in the yard as there should be. 

 

About 40min before show time I was coming down off the bucket truck (fixing the wind rearrangement of my big tree lights) and I noticed one of my channels in the yard was stuck on. It wasn't on earlier that morning but I could not have seen it during the day light.

 

Alas, some time during the day (sunny and nice all day), one of my triac turned itself on for good.  This triac when running has 100 LEDs as it's load.  Not a load issue.  Program was not active so no issue there. The sky was sunny and bright, not a weather of the moment issue.  The channel that went out did not have wet connectors at the box and not so much at the prop either since it is a mini tree that is 3' up on a rod and not on the ground.

 

So, the moral of this story is that electronics are electronics.. sometimes they just fail. It is no body's fault, the triac was not defective (on it's second season), I leave my display controllers powered 24/7 and in past 3 years this has never been an issue.  For some unknown reason it just picked this particular time to fail.  Popped in a new controller and away the show went, on time and on schedule. 

 

So now I wonder, had I not had power on it all the time, would it have failed at show time?  Would it have not failed at all?  No point in second guessing this one... replace it and continue on where I left off.  But I do wonder.... what if.....

Edited by plasmadrive

Share this post


Link to post
Share on other sites

That's how all of mine in the past have gone, wet weather the night before, next day traic failed. Have had this happen 4 times now in the past 2 seasons

Share this post


Link to post
Share on other sites

That's how all of mine in the past have gone, wet weather the night before, next day traic failed. Have had this happen 4 times now in the past 2 seasons

It was strange indeed.. it didn't fail in the wet weather or by morning.. just sometime during the day while the sun was shining and it was just sitting there.  I am glad it failed at least an hour BEFORE my show and not during, or just minutes before.  This is my first.  I did have one fail half on about 2 years back but I don't count that one.. LOL..

Share this post


Link to post
Share on other sites

I have the same issue with one of my controllers channel one stays on only half power but blinks, dimms, shimmers, but when show is over it stays on at half percent.

Share this post


Link to post
Share on other sites

I have one channel that does the exact same thing. One night after wet weather the triac went bad.

It does play fine during sequence but stays on at about 5% power.  Every year I say I'm fix but always forget...

Share this post


Link to post
Share on other sites

I have a new 16 channel unit where one of the channels has failed.  It worked at first, but failed after a rain storm as you are describing.  

 

It failed in the off position.  My question is, was the only defective part you had to replace the triac?  I have looked for a schematic of the controller, but can not find one.

 

Thanks for any help you can provide.

 

Also, I am not rushing into this since the season is now over.  I ignored it & used another channel from a different controller.

Share this post


Link to post
Share on other sites

I have yet to see a triac fail OFF.  You may have either an opto coupler problem or need to reset your controller because the processor is not outputting to that channel. 

 

There are no available schematics that I know of for the controllers.

Share this post


Link to post
Share on other sites

I have had 4 or 5 and the only real bad thing is making the card accessible to replace the triac,,,years ago light o rama just mailed me some replacements but now they give u a website where to buy them. there mostly inexpensive.  but I found out after getting to the solder joints that the suction cup DE solder  from Radio shack works good Just find out which channel it is and remove it from the controller card.  Get a half dozen or a dozen triacs cause it will happen again

Share this post


Link to post
Share on other sites

I have had 4 or 5 and the only real bad thing is making the card accessible to replace the triac,,,years ago light o rama just mailed me some replacements but now they give u a website where to buy them. there mostly inexpensive.  but I found out after getting to the solder joints that the suction cup DE solder  from Radio shack works good Just find out which channel it is and remove it from the controller card.  Get a half dozen or a dozen triacs cause it will happen again

 

This isn't completely true.  If you open a help desk ticket, tell us you have a channel out, and ask for them, we send them - as long as it's a reasonable number.  If you ask us where to buy them, ask for a supply of spares 'just in case', or if you ask for an inordinate amount, we tell you where you can buy them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...