Jump to content
Light-O-Rama Forums
beaker020

Visualizer and CCR macros

Recommended Posts

I have noticed that when I use macros on my CCR's that they sometimes don't display correctly in the visualizer. It seems to be hit or miss. If I stop and start the playback, most of the time it will correct the display but not always. For instance; if I am doing a chase, on one playback it will display full on. On the next playback it will chase properly. 

 

I am hoping this is just a visualizer quirk and it will playback properly during the actual show time. 

 

I am using LOR V3.8.2

Share this post


Link to post
Share on other sites

It is not a Vis quirk.  You need to ensure the parameters for your macros are set at least one column before you start the actual effect.  Also, if you start playing the sequence at some other time, those parameters are not being sent (since they are only sent once - when they start).  That means the visualization of those macros will be wonky - and actual hardware could be as well.

Share this post


Link to post
Share on other sites

I was aware of that and most of the events were set up that way.I just went over the sequence and made sure  all the parameters were set 1 column (0.05 sec) before the actual event and it still happens in a couple sections. I even tried setting the parameters 2 columns (0.10 sec) before the event and it still messed up. If I stop playback, back up the time scale, and resume play from selection, it plays that section fine. The next section may or may not play properly. If its just the Vis then I dont care. If its going to do this at show time then its a problem. 

 

I think I've spent more time trying to get these macros to work properly then I was hoping to save by not doing it the long way. 

Share this post


Link to post
Share on other sites

If you start a sequence in the middle of where you have a macro running, results will always be unpredictable -- even on hardware.  

 

Macros are programs that run on the controller.  The depending on what state the controller is in when they run affects how the ribbon/Vis will look.  Starting in the middle of a macro run means the controller is not in the state it would have been in if you ran the sequence from the start.  Therefore results will be unpredictable - on both the hardware and the Vis.

 

If you want to see how a macro or color effect looks, you must be sure to start the sequence from a point where the ribbon is in the correct state.  For example, any place in your sequence where the ribbon is DARK and also before where you set the parms is a good place to start playing from.  If the spot in the sequence where you start from doesn't have the ribbon completely off, results are going to look wrong.

Share this post


Link to post
Share on other sites

Starting the sequence from the BEGINNING  produces undesirable results. Starting the sequence from the middle produces desirable results. When starting from the middle I am starting where the ribbon is DARK. The only param that is set at that point is the LR,, which is set to 1 for the entire sequence. 

Share this post


Link to post
Share on other sites

I have the same issue. Visualizer hit or miss. But the good news is it always works right during the show.

Usually going to the point where I program it I can see the effect.

Share this post


Link to post
Share on other sites

Starting the sequence from the BEGINNING  produces undesirable results. Starting the sequence from the middle produces desirable results. When starting from the middle I am starting where the ribbon is DARK. The only param that is set at that point is the LR,, which is set to 1 for the entire sequence. 

 

 

Ok, then your issue is different.  You are being hit with 'Compression' and 'Random Order'.  I'll bet you are setting that LR parm in the very first column at 0:00.00 (or very close), right?

 

1 - The Sequence Editor/Show Player do not guarantee the order of output of channels to any device or the Visualizer.  As of right now, there is no notion of channel 'priority'.  Channel 120 can be sent before channel 4 and after channel 8.  

 

2 - When starting a sequence, the Sequence Editor attempts to put all channels in a known state:  OFF.  This happens at time 0:00.00.  The SE automagically issues all those off commands, and then starts outputting your sequence.  If at the time your LR command comes around the OFF command for the same channel has not yet been sent, they are compressed together.  

 

So, here we have 2 commands for the same channel in the buffer at the same time:  One an OFF command (value 000), the other the intensity 001.  Which one is going to win?  In the case of data out the wire, the order is 000,001 which is compressed into 001.  In the case of data out to the visualizer, the order is 001,000.  000 is going to win.  (See #1 - we do not guarantee order).  Another day it could be the opposite.

 

The solution is the same:  Set the parameters before you need them.  Remember at 0:00:00 at least one command is going out:  0's to the macro and color effect channels.  To you those are not really commands, but to the hardware (and Vis) they are.  Now at the same time, you are trying to set a parameter: 001 for LR, and that leads to unpredictable results -- the ones you are experiencing.  

 

To fix it, ensure there is enough 'time' at the start of your sequence for all the 'Off' commands to go out BEFORE you start sending sequence data.  A tenth of a second or 2 is usually more than enough time for everything to sync up. 

Share this post


Link to post
Share on other sites

I don't want to Hi Jack this thread from the OP but this has never worked for me. 

 

Minor inconvenience to me because I am able to see the actual macro if I start the sequence right in front of the macro.  But I have never been able to get this to work from using the start button.

 

I have gone back and looked at my sequence and it looked good.  I went ahead and made changes based on your recommendations but it made no difference.

 

In the below image, the first macro works perfect.  The second one only does fade up and fade down every pixel and not the correct macro.  If I start the sequence between the 2 macros then it works perfect.  I captured this image with Ribbon 1 Macro section and Ribbon 2 Pixel 1 in view for easy reference.  Both ribbons are programed the same.

 

I originally had LR go to 0 after the first and after every macro.  I tried it with the LR staying one.  It made no difference.  I have tried increasing the start of the Macro but that did not help either.

 

This is just 2 of the Macros on this sequence but they all behave the same and of course I programed them the same. 

 

I can send you a portion of or this complete sequence for you to look at and tell me what I am doing wrong. 

 

During the show...it works flawlessly.  Only during visualizer do I have a problem.  This was a sequence from last year.  I am pulling it forward to be used this year as well so it still holds value.

 

Thanks,

Sax

Share this post


Link to post
Share on other sites

..

During the show...it works flawlessly.  Only during visualizer do I have a problem. 

...

 

This is a key part of the discussion.      The commands operate the actual lights.  The simulation seems to work differently. 

I hate to pile on here because I am a booster for the macros and their usefulness and for the visualizer.  But I too have macro sequences which do not simulate the same.  For years I had my CCR arches set up all year in my light shop and could see the difference.   Many attempts were made to fix it in SE but it all goes back to the same commands being sent with different response. 

Share this post


Link to post
Share on other sites

Ok, then your issue is different.  You are being hit with 'Compression' and 'Random Order'.  I'll bet you are setting that LR parm in the very first column at 0:00.00 (or very close), right?

 

 

You're right. and I would almost buy this except the first few macros work fine. Its not until about the 1 minute mark that they start messing up. Thats 5 macros into the sequence and the third time I've used that same macro.

 

Just for giggles I did set the LR parm 0.10 seconds after the start and it made no difference. I also tried setting the ME and MS params several columns before I needed them.

 

Thanks Sax and Bob for confirming what I suspected. Like I said from the start; if its just the Vis then its not a big deal, as long as it plays right at showtime.

Share this post


Link to post
Share on other sites

Hopefully the next version of the software will help with some of these issues.  The next version has the idea of 'channel priority', and that should help to get the commands out in the correct order.  But again, I have to stress:

 

1 - Right now we do not guarantee output channel order.  Depending on how you have coded your sequence it may work today and not work tomorrow both on hardware AND the Vis.  Even with the changes, there is no guarantee of the order of channels being sent with the same priority at the same time. 

 

2 - The SE outputs OFF commands at 0:00.00 which could interfere with both how macros work on the Hardware as well as the Visualizer - if they are not completely sent before you start sending sequence commands.  The best practice here is to allow a few centiseconds at the start of the sequence for everything to calm down before you send commands.

 

3 - Sequence compression can cause differences on different transmission methods.  A network at 500Kbps (HS LOR network) could compress differently than a network at 1Gbps (like the link between SE and VIS).

 

4 - The current state of the ribbon effects how macros and color effects look.  That causes snowballing effects should there be a difference between a physical ribbon and the Visualizer.

 

All of these can come into play when you see differences between the Vis and Hardware when it comes to macros.

Share this post


Link to post
Share on other sites

I found a solution. 

Or at least a work around.

 

I tried setting the parms well before I needed them, several seconds even.

I tried not setting any parms in the first 0.10 seconds of the song

I tried only setting one parm at a time: MM in one column, MS in the next and visy versa. 

Nothing worked

 

Then I filed the space between the effects with  an arbitrary intensity. 50% was easy because thats the default intensity setting for the intensity tool. 

Lo and behold it works!

 

So where there is no active effect, I set MM and MS (and only those 2 parms) to 50% intensity. Other than at the very first 0.10 sec of the song they are never at 0. And the sequence plays perfectly.   

Share this post


Link to post
Share on other sites

Can you please send me both the one that now works and the one that didn't?  I want to see what the difference is in the output data from the SE to the Vis in those cases.  My email is mike at lightorama, and please put F32621-visualizer-and-ccr-macros in the subject.  Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...