Jump to content
Light-O-Rama Forums
zeighty

Anybody running S3 on a Mac (VMWare... etc.)?

Recommended Posts

Looking to see if I can run S3 via Windows emulation s/w (VMWare, Parallels, etc.).  I do not want to run dual boot (bootcamp).

 

I support Windows machines all day and about a dozen Macs, 50 iPads and over 100 iPhones.  I am a Apple nerd. 

 

Any input is welcome.  The ideal solution is LOR to embrance the Apple device world and publish a Mac OS X / iOS version.

 

Wouldn't a iPad S3 and / or controller extension be awesome. I see a lot of potential.

 

Oh yea, one more no - I will not be buying a Surface Pro to run LOR (or anything for that matter). Windows 8 is a... well perhaps my opinion doesn't matter except to me. 

 

Thanks in advance for you responses.  

 

Share this post


Link to post
Share on other sites

Although I don't run a Mac, there are others on here that do and they have figured out how to get around the USB dongle situation.

 

Try searching around; seems like there was 5 or 6 people actually running shows with Macs.

 

Dunno which emulation software they ran, but it worked.

 

 

Z-80 huh? I remember writing assembler code for that chip a long time ago. Fun stuff.

Edited by Ken Benedict
  • Like 1

Share this post


Link to post
Share on other sites

Z-80 huh? I remember writing assembler code for that chip a long time ago. Fun stuff.

 

+1

Share this post


Link to post
Share on other sites

Although I am new to this, last season being my First, and I'm not super technical. Dont know if id be able to help, but I do run my show  thru a Mac via VM Ware.  

Share this post


Link to post
Share on other sites

Hello Zeighty

 

I am also running  the sequencer on a mac 27 and a 17" macbook pro. Use a pc for the visualizer screen though.

 

Vmware,

 

But the actual shows I do run from the showtime director mp3, because the ease of use, and it never fails.

 

Mac is still not valued as it should, but it gets better in time, I think.

 

There are some projects in developpement and not 100% usefull yet in my humble opinion.

 

lets have fun with our macs

 

Dick

The Netherlands

Share this post


Link to post
Share on other sites

Ditto. I run S3 on 27" iMac via VirtualBox.

Share this post


Link to post
Share on other sites

It's good to see it works with Parallels, but what is this USB dongle you guys are mentioning?  Is that in place of the wireless link system?

Share this post


Link to post
Share on other sites

I do all of the sequences on a MacBook Pro using Parallels.  Works great and haven't had a problem.  I ran the show off the MP3 Director this past year.  I liked that I could be adjusting my sequences for added channels while I was running the show.  I am not sure which emulator is faster for this.  haven't tried Virtualbox or VMWare with LOR S3 yet.

Share this post


Link to post
Share on other sites

It's good to see it works with Parallels, but what is this USB dongle you guys are mentioning? Is that in place of the wireless link system?

Not sure if you got your answer.... The dongle is the USB to RJ45 adapter.

Edited by zeighty

Share this post


Link to post
Share on other sites

I am now a Virtualbox user and love it for LOR S3. Audacity works too, with a tweak.

Share this post


Link to post
Share on other sites

Anyone consider using Virtualbox be sure not to create your virtual hard drive too small. I was experimenting with VB and had created a 10GB VDI (the VB hard drive). When I decided to go production with it I should have started clean and given it at least 50-100GB.

With Windows XP Pro, S3, Audacity loaded I noticed that my free space was down to about 3GB.   Unfortunately, I made my drive "Fixed" and could not use the VB command to expand it easily. I may try a clone operation sometime later, but for now I just added a slave drive to put my files on as to not take up primary drive space. 

 

VirtualBox is really nice, the price is right too - $0, nada, zilch, zero. It is running on a another desktop (Windows users: that is OS X feature) as I type this. Tested it with the USB to RJ-45 adapter and 2 controllers and it works great.  

Edited by zeighty

Share this post


Link to post
Share on other sites

I am running vmware fusion 5.0.3 with lor s3  3.10.6  and experience often a lot of problems with heavily distorted audio. It seems that when editing the sequencer, some action is running on the background, that takes a lot of processor time.

 

Switched to maximum performance setting in windows where possible, and this seems not the solution, it does not change,     running imac 27  I3   8 gb.     4400 mb for windows vista

 

this problem did not occur with 3.9.x or earlier versions.  What has changed in 3.10.6 that eats so much processor power that audio is not handled correctly??

 

lights seem to be switched on time, also the visualiser, on an other pc, seems to be correct in timing too.

 

( The problem looks a lot like running the sequencer  with setting for visualiser to    on   , while  the second pc is not running. so data to second pc cannot be send to second computer, because  ip adss does not exist.)

 

 

 

anybody a hint for me?  Perhaps  Developer Mike??? or anybody who knows windows very well?

 

Dick de Wit

The Netherlands

www.dansendelichtjes.nl

Share this post


Link to post
Share on other sites

A second problem occurs

 

I am not able to play with  1/2 ,  1/4 , or 2x or 4x speed. whatever I choose the speed remains  1x

 

I am lost by now.

 

Who has the knowledge to explain to me what is going wrong?

 

Dick de Wit

The Netherlands

Share this post


Link to post
Share on other sites

I run S3 on Parallels 8 under OSX Mavericks.... It works fine. I run it off an old macbook pro with no glitches or anything... I just have the computer scheduled to turn on and off each day, no touch for all of december and the shows run without a glitch

Share this post


Link to post
Share on other sites

My show runs on a 1ghz Windows XP machine and I am doing all my sequencing on an 8 core Mac Pro with Parallels and WinXP. Sync is iffy at best between the two systems.

Share this post


Link to post
Share on other sites

I got started with VirtualBox (free) on a 10.7 Mac.  USB works fine. It is driving my first 6 channels as we speak.

 

You can also get an downloaded evaluation copy of Windows valid for 90 days, too, so at least getting started has been free. Well, after dropping a bundle to lightorama :-)

 

I do wish I could at least do the sequencing on a Mac. 

Share this post


Link to post
Share on other sites

I am running S3 on MacBook Air and Mac 27" OSX Maverick and Parallels with Windows XP.  No Problems here

Share this post


Link to post
Share on other sites

Mac guy.  Just got Parallels and Windows 7 for the first time just for LOR show.  All seems fine with windows, but when I launch LOR control panel to set up, it won't allow me to create the folder for sequences, then says LOR wasn't installed correctly.  Uninstalled and re-installed.  (This is the reason I go with Mac).

 

Any ideas?  Thanks,

 

Ed Walker

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...