Jump to content
Light-O-Rama Forums
DevMike

S3 E1.31 if you do NOT have an LOR RS485 USB adapter

Recommended Posts

DevMike    429

This is only needed for S3.  S4 no longer requires these steps

 

 

The DMX listener of the LOR S3 software suite requires several library files to already be in place before it will start correctly. These libraries are typically installed the first time you connect an LOR USB RS485 adapter. However with the advent of E1.31 support, you may never have a need to use one of these adapters.

This procedure should only be followed if the following 4 things are true:

  • You are using E1.31
  • You do not have access to a USB485 adapter AND have never had one connected to the computer in question.
  • You are running any version of S3.  S4 does not require this setup.
  • You are experiencing this repeating error in the control panel:

[time]: DMX listener error 3: Comm Winsock Error / 10061: Connection is forcefully rejected



If you are not using E1.31, or do not have this error you can ignore all of this. It does NOT apply to you.




If you are using E1.31, are getting the error, and have access to a USB485 adapter, it is much simpler to just install the drivers, attach the adapter to a USB port and wait for the driver installation to complete. You can then disconnect the USB adapter - you'll no longer need it and you do NOT have to follow these instructions.




If you are using E1.31, are getting the error, and do NOT have access to a USB RS485 adapter, follow these instructions:

  • Download the ftd2xx.zip file from here:ftd2xx.zip
  • Download and install the CDM20830_Setup.exe file from here: http://www1.lightorama.com/firmware-updates/'>http://www.lightorama.com/Firmware.html (at the bottom)
  • Reboot
  • From the start menu or desktop, double click on 'Computer' or 'My Computer'
  • Double click the boot hard drive (Typically C:), then double click on the 'Windows' folder. NOTE! At any time you may get a security warning, or other access control message. Simply select the option that allows the task to continue.
  • If you are running a 64 bit version of Windows, double click on the SysWOW64 folder. Otherwise, double click on the system32 folder. If you are unsure if you have a 32 or 64 bit OS, just carefully search the windows folder. If you do NOT see a SysWOW64 folder, you have a 32 bit OS.
  • Extract the ftd2xx.dll file from the ftd2xx.zip file into this folder. You MUST extract the file. Copying the ZIP won't work.
  • Reboot
  • Start the LOR Control panel

The LOR Control panel should now load up, and the listener should start. If you get a Windows firewall message, you must ALLOW the LOR Listener.

If this did not fix your problem double check to make sure you put the DLL into the correct folder (SysWOW64 or system32). If you have a 64 bit OS and put the file in system32, the error will reoccur. Also beware that for 32 bit systems there is a 'system' and a 'system32' folder. You need SYSTEM32. Be sure that you have EXTRACTED the .dll from the .zip.

  • Like 3

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×