Jump to content
Light-O-Rama Forums
Sign in to follow this  
deej012160

New CTB16PC will not power up. What to do next?

Recommended Posts

I just received my first CTB16PC today. Took everything out of the box, ran the USB driver software, etc etc. Applied 120 VAC to the power plugs but the red LED that is supposed to be flashing on the circuit board is not flashing. Arrgh. No doubt I have 120VAC power on the power strip as I checked it with some light strings. I plan to check the fuses first. Any ideas what to check next? Or just plan to return to LOR?? Thanks very much in advance.

Share this post


Link to post
Share on other sites

first off if you have a new board gen 3 the led will be green. second did you plug in both power cords? it will work with just one but it has to be the right cord,the one that powers 9-16 also powers the board

Share this post


Link to post
Share on other sites

Thanks for the quick reply James!! Yes I plugged in both cords into a power strip. I checked some really obvious stuff. I have 120VAC at the plug-in terminals of the power strip and both fuses are good; both are zero ohms. I don't see anything that jumps out at me on the board. The white/black male/female terminal connectors are tight on both power supplies, so I don't think there is a problem there...

Share this post


Link to post
Share on other sites

try to find the controller in the hardware utilitiy,the led may be bad or installed backwards,if that fails you will probably need to open a ticket and send it back to lor

Share this post


Link to post
Share on other sites

If these ideas do not work, might I suggest that you contact the help desk. They're good at getting back to people.

Share this post


Link to post
Share on other sites

I did request help from LOR last night once I verified the fuses were good and that I had good 120VAC at the power outlets I was using. Thanks for the replies!! I re-sent the request tonight after swapping fuses as suggested by the LOR tech.

Share this post


Link to post
Share on other sites

I never followed up on this set of posts. LOR sent me another controller and I returned the original controller. All is well!!! Woohoo. Was very exciting to see it controlling 16 channels in my living room. As a matter of fact, once I saw 16 sets of lights doing their thing, I decided not to "stay with" just 10 channels (my original plan--my 1st year....) and go for 16 channels. Glad I went there. Anyway, this particular chapter was closed very nicely by LOR.

Edited by deej012160

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...