Jump to content
Light-O-Rama Forums
Sign in to follow this  
travis p

why iosan t visulizer the default to open lee files after upgrade to 3.2.0

Recommended Posts

whats up ever sence i ugraded to 3.2.0 and open the visulizer is asks if i want to fix it where it will open lee files ???

Share this post


Link to post
Share on other sites

say yes. It's a windows thing so that if you click on a .lee file it will open in the Visualizer, where as before if you clicked on a .lee file it asked if you wanted to look on the internet to find a program to open that type file. just say yes and you'll be fine.

Share this post


Link to post
Share on other sites

If you answer yes it asks every time you open visualizer; however if you answer no it then asks if you want LOR to continue doing the check. If you then answer no it stops asking. At least that's the way it works on Win7. Opening a ticket, this is a pain!

Share this post


Link to post
Share on other sites

We had this issue in beta, but I thought it was resolved. Maybe DevMike can chime in here and help.

Share this post


Link to post
Share on other sites

I thought I had squashed this bug in beta, but it looks like I didn't fix it all the way.

It shouldn't be doing that. The only reason it should ask again is:

1 - If something else has already taken the .lee extension.
2 - If something is preventing the program from saving the association in the registry (IE, you have some kind of software running that prevents changes).
3 - If something steals back the association.

If you are being prompted multiple times to associate .lee files, do what Ainsworth did: Say 'No' to the 'Do you want to assoicate .lee files', and then say 'No' to 'Do you want to continue doing the check'.

I'll have a look at this Monday.

Share this post


Link to post
Share on other sites

Having the same issue but sometimes bugs can slip through the system so no problem.
Will wait for the patch/fix
FYI - running Win 7 Home Premium SP1

Share this post


Link to post
Share on other sites

ainsworth : Are you using Windows 7 as well?

Are there any of you who are having this problem who would like to help me? You'll have to by hand replace your existing Visualizer.exe with a special one I'll prepare, run it, and send me the output. I can't seem to duplicate this on my development machines.

Share this post


Link to post
Share on other sites

mike when i try to set file default here>Control PanelProgramsDefault ProgramsSet Associations lee file is not listed

Share this post


Link to post
Share on other sites

Thanks. No need now. I've duplicated the issue.

Oh Microsoft User Access Control. How do I hate thee? Let me count the ways...

1
2
3
4
...
998,901
:(

The .lee file association may not be working in Windows 7, because of changes Microsoft made to the way UAC works. I have all that turned off, so I never noticed it....

ANYWAY... If you have Windows 7, here are the steps to get around this error (and get .LEEs associated correctly).

http://forums.lightorama.com/forum77/32535.html

Share this post


Link to post
Share on other sites

0000153 Editor major assigned (Mike) 2012-03-04 UAC prevents Visualizer from correctly creating HKCR entries for file associations

Share this post


Link to post
Share on other sites

that seems to have done the trick mike thanks why do i have to bother you only on sundays many thanks

Share this post


Link to post
Share on other sites

Jeff Millard wrote:

DevMike wrote:
I thought I had squashed this bug in beta, but it looks like I didn't fix it all the way.

Funny, I though I had indicated that there was no change in the way it behaved before and after the release that was supposed to have fixed it.

Jeff


Funny... I thought I had posted a procedure for you to follow in the beta board on Feb 9th, and when you didn't post back I thought it had fixed the problem.

Share this post


Link to post
Share on other sites

3.2.4 has been released which addresses this issue. There is no more need for the workaround posted.

If you are still experiencing problems, please let me know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...