Jump to content
Light-O-Rama Forums
Sign in to follow this  
Denise Brunner

Anyone else having more problems with G3 controllers

Recommended Posts

I have 20 controllers, 11 are 2+ years old and the only problem I have had have been self caused (cat 5 connectors pulled out). Out of the 9 new Controllers I have purchased this year 2 have caused me problems on the electronic end. One has a bad triac and the other one I just noticed is not operating at all. I can not get into the controller tonight to try a reset, but it just seems weird that I have had rock solid performance with the earlier versions, but am starting to question the G3. Any one else having problems????

Share this post


Link to post
Share on other sites

I have 2 of the old 1602's and 4 of the new CTB16's all running the same led lights, the 1602's have been near perfect, but the new CTB16's have been a real problem, so far I have lost about 15 triac's I was lucky that I had a few spare channels.
so far I am not impressed with the CTB16 G3's.
However, it is nice to know that LOR stand behind their product and will deal with these problems, this gives me the confidence in LOR to buy more stuff this year :cool:

Share this post


Link to post
Share on other sites

I love LOR and would not even think about using anything else. LOR is one of the few companys that stand 100% their product!!! Just wanted to see if it was something with my wiring and/or setup.

Share this post


Link to post
Share on other sites

Opened enclosure up and found no light on the board. Right away I though ok, no power. Took my voltage meter and tried to check voltage both before and after the fuse and all of a sudden the board came to life. The red LED came on solid and it started working !!! I shook the board, moved wires around and it just kept working. I have NO clue what was wrong. Will see what tonight brings.

Share this post


Link to post
Share on other sites

I'm glad it started working, Denise. It drives me nuts, however, when you don't know why it didn't work or why it now works.

I hope it stays working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...