Jump to content
Light-O-Rama Forums
Sign in to follow this  
Guest Don Gillespie

Changing contoller ID numbers

Recommended Posts

Good find there James! I wonder how it will not recognize it but still work?

Share this post


Link to post
Share on other sites

How can you change the controller ID or update firmware on Gen 3 controllers with S2 then?

Share this post


Link to post
Share on other sites

Don,

Go to Lor website, open a support desk ticket.

The S2 software will controll a Gen 3 controller but the Hardware Utility in S2 has problems with Gen 3 boards.

Thats why I asked about your software, but got busy here
at work before I could reply.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Don,

Go to Lor website, open a support desk ticket.

The S2 software will controll a Gen 3 controller but the Hardware Utility in S2 has problems with Gen 3 boards.

Thats why I asked about your software, but got busy here
at work before I could reply.


Thanks John I am updating to S3 anyways so might as well be sooner than later

Share this post


Link to post
Share on other sites

Ok, Don. :):)

I have a feeling that as more Gen 3 controllers are shipped to folks still using S2 software, that this is not the last post we will see on this subject.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Ok, Don. :):)

I have a feeling that as more Gen 3 controllers are shipped to folks still using S2 software, that this is not the last post we will see on this subject.[/quote

Thanks John I thought I was losing my mind

Share this post


Link to post
Share on other sites
Guest Don Gillespie

Here is what LOR told me
You won't need to upgrade to resolve the issue. If memory serves (and without going to check) it's nothing more than the firmware of the G3 controllers not being defined in S2.



There should be no side effects, just the HWU won't see the number.



I thought I would post this so if anyone else comes across this we would have an answer.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

working with LOR right at the moment to solve this issue my computer keeps telling me a comm port is opened and so I can't seem to get anything fixed still the HWU can not find the G3 contollers I have downloaded the driver for the USB485 connector still no response. will keep you posted.:) I do not know how to check to see what keeps a comm port open

Share this post


Link to post
Share on other sites
Guest Don Gillespie

Ok I just retried an old contoller the HWU found it in a couple of seconds but when I hooked up the new G3 it does not find it at all we will get this resolved thought I would keep you updated so if it does happen to any one else we can help them.

Share this post


Link to post
Share on other sites

I did my new g3 controllers last night but I upgraded the software to most current version before doing do. I had to click on Auto configure a couple of time as it was not recognizing the Comm Port, but did work just fine eventually. Did you click on Auto Configure?

Share this post


Link to post
Share on other sites
Guest Don Gillespie

Greg Blauert wrote:

I did my new g3 controllers last night but I upgraded the software to most current version before doing do. I had to click on Auto configure a couple of time as it was not recognizing the Comm Port, but did work just fine eventually. Did you click on Auto Configure?

Ya I tried that but will try anything at this point. so what soft ware are you using now I am currently using 2.9.4 Advanced

Share this post


Link to post
Share on other sites

Greg Blauert wrote:

I did my new g3 controllers last night but I upgraded the software to most current version before doing do. I had to click on Auto configure a couple of time as it was not recognizing the Comm Port, but did work just fine eventually. Did you click on Auto Configure?



Don's issue is he is still using S2 2.9.4 software, not S3 3.0.2.

LOR S2 software does not know what a new Gen 3 controller is.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Greg Blauert wrote:
I did my new g3 controllers last night but I upgraded the software to most current version before doing do. I had to click on Auto configure a couple of time as it was not recognizing the Comm Port, but did work just fine eventually. Did you click on Auto Configure?



Don's issue is he is still using S2 2.9.4 software, not S3 3.0.2.

LOR S2 software does not know what a new Gen 3 controller is.

John it sounds to me that upgrading to the S3 software will solve my problem and I don't have a problem with that will purchase it right away and keep you informed.

Share this post


Link to post
Share on other sites

Don,

That has been the problem all along. LOR S2 was released way back in 2008 and 2.9.4 was released in Dec 2010. The new Gen 3 controllers did not exist then, so S2 software doesn't know what they are or that they even exist.

We had to upgrade our software in Oct 2009 when the CCRs were first introduced, as the previous versions didn't know what they were.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Don,

That has been the problem all along. LOR S2 was released way back in 2008 and 2.9.4 was released in Dec 2010. The new Gen 3 controllers did not exist then, so S2 software doesn't know what they are or that they even exist.

We had to upgrade our software in Oct 2009 when the CCRs were first introduced, as the previous versions didn't know what they were.

makes perfect sense John I was looking inside the box instead of outside the box the solution was too easy

Share this post


Link to post
Share on other sites

Don, the reason I asked you to open a support ticket yesterday was so that there would be an "official" heads up to LOR that this was going to be an issue as the new Gen 3 controllers are being shipped out and "old diehards" are still using S2 software.

As busy as LOR is right now, they don't have time to monitor the "newbie" forums fot something like this.

Maybe if the post had been started in the Hardware section, someone might have seen it, or maybe not.

Share this post


Link to post
Share on other sites

Don Gillespie wrote:

Paul Roberson wrote:
I'm with Pete I thought the LORTray needed to be 'unloaded' for firmware upgrades?

First I have heard of this, I am running the 2.9.4 Advanced the new controllers are the G3 don't know if that makes a difference or not, no panic yet lots of time to get this issue resolved.


Just for the record, the Control Panel does NOT have to be closed when using the Hardware Utility.

This issue is as stated previously. S2 software not reconizing a new Gen 3 controller. S3 software will work great.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Don, the reason I asked you to open a support ticket yesterday was so that there would be an "official" heads up to LOR that this was going to be an issue as the new Gen 3 controllers are being shipped out and "old diehards" are still using S2 software.

As busy as LOR is right now, they don't have time to monitor the "newbie" forums fot something like this.

Maybe if the post had been started in the Hardware section, someone might have seen it, or maybe not.

Thanks John one more question for you I am currently running 2.9.4 Advanced when I go to the upgrade page I have no clue as to what I should get it is not showing me that option it shows basic to basic plus so I am confused on which one to get I want the best any recomendations secondly I am going to e-mail LOR and see if they can move this thread to the hardware section where it belongs

Share this post


Link to post
Share on other sites

Okay. I just wiped out 3.0 on a computer, and re-installed 2.9.4.

I can see a G3 controller, though I get the expected "Unknown Device???" text instead of the version.

I was also able to change the ID from 01 to 04.

The controller responded to commands sent to it via the HWU.

It also responds to commands sent to it from the SE.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

Don wrote:

Okay. I just wiped out 3.0 on a computer, and re-installed 2.9.4.

I can see a G3 controller, though I get the expected "Unknown Device???" text instead of the version.

I was also able to change the ID from 01 to 04.

The controller responded to commands sent to it via the HWU.

It also responds to commands sent to it from the SE.

interesting my HWU doesn't even recognize the controller

Share this post


Link to post
Share on other sites

Don Gillespie wrote:

interesting my HWU doesn't even recognize the controller

No idea. That's an odd one.

I've re-assigned your ticket to Dan/Bob. They are going to have to look at this one. I don't know the answer.

Share this post


Link to post
Share on other sites

Don wrote:

Okay. I just wiped out 3.0 on a computer, and re-installed 2.9.4.

I can see a G3 controller, though I get the expected "Unknown Device???" text instead of the version.

I was also able to change the ID from 01 to 04.

The controller responded to commands sent to it via the HWU.

It also responds to commands sent to it from the SE.



Thanks Don,

I did not have a Gen 3 controller on hand to test with, I was trying to think through the logic similar to what happened when I received my CCRs and the current software at that time (2.4.08) required them to be operated only in legacy mode. Thank goodness 2.5.2 was released quickly on 10/16/09 that fixed it.

Share this post


Link to post
Share on other sites

Don Gillespie wrote:

JBullard wrote:
Don, the reason I asked you to open a support ticket yesterday was so that there would be an "official" heads up to LOR that this was going to be an issue as the new Gen 3 controllers are being shipped out and "old diehards" are still using S2 software.

As busy as LOR is right now, they don't have time to monitor the "newbie" forums fot something like this.

Maybe if the post had been started in the Hardware section, someone might have seen it, or maybe not.

Thanks John one more question for you I am currently running 2.9.4 Advanced when I go to the upgrade page I have no clue as to what I should get it is not showing me that option it shows basic to basic plus so I am confused on which one to get I want the best any recomendations secondly I am going to e-mail LOR and see if they can move this thread to the hardware section where it belongs


Don G,

You need to RENEW your license, not upgrade. Go to this page:

http://store.lightorama.com/solire.html

As soon as you download your software, your license key will allow you to use in the Advanced mode.

Share this post


Link to post
Share on other sites
Guest Don Gillespie

JBullard wrote:

Don Gillespie wrote:
JBullard wrote:
Don, the reason I asked you to open a support ticket yesterday was so that there would be an "official" heads up to LOR that this was going to be an issue as the new Gen 3 controllers are being shipped out and "old diehards" are still using S2 software.

As busy as LOR is right now, they don't have time to monitor the "newbie" forums fot something like this.

Maybe if the post had been started in the Hardware section, someone might have seen it, or maybe not.

Thanks John one more question for you I am currently running 2.9.4 Advanced when I go to the upgrade page I have no clue as to what I should get it is not showing me that option it shows basic to basic plus so I am confused on which one to get I want the best any recomendations secondly I am going to e-mail LOR and see if they can move this thread to the hardware section where it belongs


Don G,

You need to RENEW your license, not upgrade. Go to this page:

http://store.lightorama.com/solire.html

As soon as you download your software, your license key will allow you to use in the Advanced mode.

Thanks John :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...