Jump to content
Light-O-Rama Forums
Sign in to follow this  
kneel999

Can't get my 12 ccr's to play nice together

Recommended Posts

In my ongoing frustration with superstar and S3, I have tried everything. I believe I have all the CCR controllers set up properly (all assigned sequential unit ID numbers and all in standard not legacy mode) and the configuration settings in superstar are set up with regular network comm3, Aux A comm4, Aux B comm 5, and even the network preferences in the LOR sequence editor are set up. I have 3 USB485 connectors, one for my 5 LOR 16 channel controllers and 2 for my CCR's. I have the comm settings set up properly. I have tried several short programs in superstar with different settings and nothing works. This is a link to what one looks like in the superstar program:
http://youtu.be/UcBMCoiThZo
and this is what it looks like when run through the CCR's (garbled, upside down and backwards):
http://youtu.be/B9Akxx_3NoU
I spent all day on this and I can't figure out why this won't work. I thought the superstar program was supposed to make using these CCR's simple. I've seen some others run their LOR controllers and 12 CCR's on 1 USB485. I've heard that's not desirable and that's the last thing I haven't tried, although it IS supposed to work the way I have it and I am at a loss of what to try next.

Share this post


Link to post
Share on other sites

I haven't got that far yet, but I have a similar setup.

I spent most the afternoon yesterday trying to get a CCR grid to work in the visualizer. One confusing item (for me) was the configuration setup dialog that displays the networks in decimal - hex order.

Can you post a picture of your Configuration Setup dialog? Also, have you tried to display the CCR grid in the visualizer?

Dan

Share this post


Link to post
Share on other sites

I haven't tried it in the visualizer yet.
I was confused originally by the unit ID's also and looking at the help file
in superstar software it says it assumes the CCR's are in sequential order from
the first one so I wanted to make sure they where correct so instead of #10-15 I made it 0A to 0F (which if you set the unit ID's from hardware control panel in LOR it shows the first "number" after number 9 being 0A not 10.
Then my numbers 16-21 are actually 16-10 through 21-15.
I don't understand why the numbers go in this weird order. I think I have it correct though.

config.JPG

Share this post


Link to post
Share on other sites

The controllers IDs are always referenced in the hexadecimal format

Share this post


Link to post
Share on other sites

Except in the SS Config dialog. The decimal value is first followed by the equivalent hex number.

Share this post


Link to post
Share on other sites

A couple of things I would look at. After the export, open the lms file into LOR. Open the channel config dialog and look at the start of the first CCR string. Make sure it is starting at 0A and not 01.

Next, I would try unchecking the standard network. SS should not have to know about this network, since it doesn't use it. (I am only taking a best guess on this! If you neighbors house lights start blinking when you test this, I got it wrong.)

I attached my config setup below. It works in the visualizer - and thats as far as I can test for now. I have two CCRS on the standard nework starting at 0x51 and 0x52. All the rest are on the Aux networks and all are in sequential order - no gaps. The normal controllers are all below 0x51.

Good luck,
Dan

Attached files 271320=15002-Configuration Setup_2011-10

Share this post


Link to post
Share on other sites

DanR wrote:

Except in the SS Config dialog. The decimal value is first followed by the equivalent hex number.

That is a software thing. The actual controller ID is in Hex

Share this post


Link to post
Share on other sites

OK, I'm half way to a solution.
I connected each CCR one at a time to my laptop with the hardware utility open.
I unplugged the CCR and while holding the reset button I plugged it back in an continued to hold the reset button for at least 5 seconds. (I'm not sure what the reset button does because I refreshed the hardware utility to make sure it found the CCR's after the reset button, which it did, and all the settings such as unit ID and CCR config settings were all the same as before I reset it)
Anyway, they are now reacting as they should with no weird colors or extra pixels.
YEAH!

Second problem though.

The sequence plays upside down.

I've told superstar that Aux A is channels 0A-0F and Aux B is 16-10 to 21-15, you can see that in my image from a previous post. I checked the channel property grid in LOR sequencer and it looks correct also. I don't know how this is getting reversed somehow. (and yes I double checked to make sure they are all plugged in correctly in the proper order)
channelGrid.JPG

Share this post


Link to post
Share on other sites

First, congrats on the progress!

Where is your CCR1?

I remember reading somewhere that CCR1 is supposed to be on the bottom. (I don't remember where I read that though)

Share this post


Link to post
Share on other sites

It is on the top.
I thought about just switching all the cables around (reversing their order from top to bottom)
I'm not sure if that will work or not but if it does that seem like a weird solution.
Otherwise I'll try putting the CCR1 on the bottom and CCR12 on the top and see if that works. I'll keep you posted.
I also asked the Author of the superstar software the upside down question. Hopefully I'll get an answer from him also.

Share this post


Link to post
Share on other sites

Just another side note.
It seems like this was a known issue that may still be an issue. This was from December 2010.
I found this on the superstarlights forums:

PMC wrote:I loaded PacMan Animation and since I am doing a matrix the animation is upside down when you play it, any way to do a 180°turn on this?


thanks

-paul



Yes, you're right, back when I did the PacMan animation I was working with the vertical ribbons only and I didn't plan ahead for the ribbons being horizontal. And you can rotate text, but there currently is not an option to rotate images. So your best option is to go into the images for the pacman animation and see how they are drawn and then create images that are upside down relative to the current images. If you redefine the images, the whole animation can use the redefined ones. Now that I think of it, I can do that too, and have that in the next release this weekend.

Share this post


Link to post
Share on other sites

OK ladies and gentlemen, last post I promise.
I reversed the order of the CCR's so that number 1 is on the bottom row and number 12 is on the top and that fixed the upside down issue.
IT'S WORKING!!
Thanks

Share this post


Link to post
Share on other sites

Excellent! I'd like to see a video when you get a chance.

Dan

Share this post


Link to post
Share on other sites

Here is a first look at it. I probably should have been a little farther away when I took this.

Share this post


Link to post
Share on other sites

kneel999 wrote:

OK ladies and gentlemen, last post I promise.
I reversed the order of the CCR's so that number 1 is on the bottom row and number 12 is on the top and that fixed the upside down issue.
IT'S WORKING!!
Thanks


Thanks everyone for figuring this out. Sorry I didn't do a good job of monitoring everyones questions. The sequences looks great!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...