Jump to content
Light-O-Rama Forums
Sign in to follow this  
ItsMeBobO

Introducing Macro Maestro

Recommended Posts

This started out as a personal quick reference guide. But as I got going I realized I could animate each macro to verify the movement is what I wanted.

For those of you who are trying to get a grip on using macros here is your tool. With Macro Maestro you don't even need to touch the intensity tool. Just slide to the values you want, check out the image, click export and its ready to use in your sequence.

Features:
Visually see what each effect and its settings will look like.
Export the settings to a clipboard file you can use in SE.
Free but expires so new features can be sent out.
Not affiliated with or approved by LOR.

This is the first release so send bug reports if you find them.

MacroMaestro.gif

http://itsmebob.com/Christmas/2010/MacroMaestro.exe

Share this post


Link to post
Share on other sites

I placed the MacroMaestro.exe in my LOR directory under My Documents folder and it wont run it just gives me an error that "MacroMaestro has stopped working". This is on my laptop running Vista.

Share this post


Link to post
Share on other sites

kzaas wrote:

I placed the MacroMaestro.exe in my LOR directory under My Documents folder and it wont run it just gives me an error that "MacroMaestro has stopped working". This is on my laptop running Vista.


Are you using BitDefender anti-virus V10 by any chance?
I googled your error and find many people complain of this problem with various sofware.

Are you able to check your EventViewer? If the faulting module is sockspy.dll (a BitDefender module) BitDefender forum recommends renaming sockspy.dll to sockspy.dl_

Share this post


Link to post
Share on other sites

Thanks Bob - this looks great! I just downloaded it and am on my way to hit the sack. But I'm looking forward to trying it out later on today.

Share this post


Link to post
Share on other sites

Actually I have recently removed my antivirus to allow me to install another program and haven't gotten back to putting it back on. I looked in the event viewer and the only changes I am seeing to the log each time I try to run the program in a security audit process.

Share this post


Link to post
Share on other sites

It looks fab, Bob

However, I get two .NET 2.0 Runtime Error Reporting from the Application (see attachment)




Attached files 209281=11659-BobO_1.PNG

Share this post


Link to post
Share on other sites

omG, I have just realised that this computer name is spelt incorrectly ... :shock:

Now, I have to change it!



Btw, Bob, I am running XP pro here ...



Cheers:)

Share this post


Link to post
Share on other sites

MacroMaestro is a windows VB.net program so you must have the framework installed for it to run.

The program has been recompiled using .Net framework 3.5

Thank you so much for the detailed error pictures. It turns out that error was specific to .net 2.0 which is old now.

Share this post


Link to post
Share on other sites

I am on Vista too and it just brings up the error:

MacroMaestro has stopped working

A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

Share this post


Link to post
Share on other sites

I'm running the program (or attempting to) under Windows 7 with .NET 3.5 (latest updates) and it's also reporting it stopped working and searching for resolution.

-Gary-

Share this post


Link to post
Share on other sites

Update

I thought I had downloaded and saved the program. But this morning I couldn't find it so I tried downloading it again. I can't get it past Norton AV. Norton seems to think the program is a medium-level threat and keeps deleting it. I don't have the time to fart around with it right now - the weather is too nice and I have too many things to create for the yard - so I'll report back again tonight.

Share this post


Link to post
Share on other sites

NP George. So sorry people are having problems. It would be nice if someone would say they got it to run!

The problems people are having appear to be security related. It runs fine on my developer desktop. I will go to my wife pc and see if I can run it there.

In the mean time I have changed the compile options again to see if that makes a difference. Now version 1.0.0.2
http://itsmebob.com/Christmas/2010/MacroMaestro.exe

Share this post


Link to post
Share on other sites

I just tried it and got the error also.

What kind on info would you like on the error?

Running XP Pro SP3.

Share this post


Link to post
Share on other sites

Bob, here's the event log for the program run failure. See if it gives you any clues:

Fault bucket 1316548058, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: macromaestro(2).exe
P2: 1.0.0.1
P3: 4c67e58e
P4: MacroMaestro
P5: 1.0.0.1
P6: 4c67e58e
P7: d
P8: e0
P9: System.InvalidOperationException
P10:

Attached files:
C:UsersGaryAppDataLocalTempWER30D0.tmp.WERInternalMetadata.xml

These files may be available here:
C:UsersGaryAppDataLocalMicrosoftWindowsWERReportArchiveAppCrash_macromaestro(2)._99b6c16b1577a3bb99611c141e4abf2a1694d083_00598559

Analysis symbol:
Rechecking for solution: 0
Report Id: b95ce52e-a892-11df-bfb7-00508d677104
Report Status: 0

Share this post


Link to post
Share on other sites

Thanks to all and sorry for the false start. When we get this going I really need a new thread!

I found the problem with a drawing object which is not a standard part of the .net client. That has been removed and version 1.0.0.3 is now deployed, same link as before. I test DL'd this to my wifes PC and it worked this time.

Please check you are using version 1.0.0.3 Sometimes if you have downloaded the same filename, your browser will pick up the old version. If this happens to you, please clear your cache. Cntl-f5 sometimes works for that.

Share this post


Link to post
Share on other sites

I think I'm missing something here. I can export, but then I don't see the "load clipboard" option. Actually I don't see any clipboard options. Do i need to install something in LOR?

Share this post


Link to post
Share on other sites

Victory402 wrote:

I think I'm missing something here. I can export, but then I don't see the "load clipboard" option. Actually I don't see any clipboard options. Do i need to install something in LOR?


New feature in the left panel. Expand the left panel with the magnifier glass at top. Click the Load Clipboard button and it present a file selection dialog. Select the file created by MacroMaestro. Make sure you have that newly loaded clipboard selected with the radio button next to it. Set the by time/by cell paste to your preference.

If you use by time, MM gives you 5 seconds as an example. If you use by cell MM gives you only 5 cells.




ClipBoard.jpg

Share this post


Link to post
Share on other sites

1.0.0.3 appears to run happily enough on my Vista Ultimate (32 bit) system.
Have not tinkered with the export function tho...

-jim

Share this post


Link to post
Share on other sites

Bob, it seems to be working as it should :)

This will be a hugh timesaver. Thank you!

Share this post


Link to post
Share on other sites

Working like a champ here Bob! This is gonna save OODLES of time! Thank you for a wonderful tool!

-Gary-

Share this post


Link to post
Share on other sites

Thanks BOB.

Very nice.

This will defiantly save me lots of time.

Job well done.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...